Friday, December 10, 2010

New Dell MP (4.1, A00) has been released

Just got word that the latest Dell MP, version 4.1 A00 has been released.

Besides a fix for the Discovery issue(!) it contains these improvements:

  • Support for OpenManage events up to version 6.4;
  • Management of physical and teamed Network Interfaces for Broadcom and Intel NICs;
  • Enriched monitoring of Network Interfaces on OpenManage Server Administrator versions greater than and equal to 6.2.0.1, along with basic monitoring on OMSA versions below 6.2.0.1;
  • Performance monitoring of Network Interfaces on OpenManage Server Administrator versions greater than 6.2.0.1;
  • Discovery of vflash card and monitoring of iDRAC network interfaces;
  • Realistic icons for the various components in Diagram View for the Dell Monolithic and Modular Systems;
  • Representation of Server Modules and Chassis Slots Summary under Dell Chassis Management Controllers and Dell Modular Chassis Remote Access Controllers;
  • Correlation of the Server Modules under Dell Chassis Management Controllers/Dell Modular Chassis Remote Access Controllers with Dell Windows Servers on System Center Operations Manager 2007 R2.

MP can be downloaded from here.
image

9 comments:

DarkDim said...

Arrrrrhhhhh, discovery script still fails intermitantly with an "Object loop retrieval error" and servers end up in the unmanaged group. Raising a call with Dell now...

Marnix Wolf said...

Hi DarkDim,

sounds bad. Does this happen on all Dell servers or only on a certain set?

Cheers,
Marnix

Andrew said...

This is what I do not like about this MP:

"The recommended version of Dell OpenManage Server
Administrator is 6.4 however, required version is 5.5 to 6.4 "

OpenManage is a funny application. Older versions (less than 5.5) are still available for download, and older hardware cannot always run newer versions of OM. About 1/4 of our Dell hw (of about 2000 servers) have older versions that go into Unmanaged.

HPs MP is much nicer and is not so picky about discovery.

Just my 2 cents.

Marnix Wolf said...

Hi Andrew.

Thanks for visiting my blog and your comment.

Of course, there is always room for improvement with any MP. But still I thing the current Dell MP is a huge improvement compared to the old versions.

Perhaps it is a good idea to give your feedback of the Dell MP also to Dell itself? The more comments they get, the more they know what their customerbase requires.

Cheers,
Marnix

Guille said...

Darkdim look this

Hit the same thing and managed to fix it by writing a powershell script that runs the WMI query every 30 seconds. Leave the script running for at least 24 hours so SCOM can run Dell discovery on all machines in the environment.


$servers = gc .\serverlist.txt

while($true)
{

foreach($server in $servers)
{
write-host "unfscking omsa detection on $server"
$result = Get-WmiObject -query "Select * from DELL_SoftwareFeature" -namespace root\cimv2\dell -ComputerName $server
if($result -eq $null)
{
"$server failed to return data for Dell WMI Query"
}
}
"Pass complete."
sleep 30
}

Marnix Wolf said...

Hi Guille

Thanks for the update and script. However, how about the load and performance hit? Running this so often in enterprise environments can cause some issues I am afraid. So be carefull with it.

Cheers,Marnix

Adam said...

OpenManage 6.4 has fixed all my discovery issues.

Abu Syams said...

how about HP Blade? is there any information?

Marnix Wolf said...

Wish I knew. Hope it will come out soon. Cheers, Marnix.