Tuesday, April 24, 2012

HP Storage MP v 2.1: Empty HP Storage P4000 Diagram View is by ‘design’…

Imported the HP Storage MP v 2.1 for a customer of mine in order to monitor a HP P4500 SAN. Followed the guide the whole way through and configured the MP and the other components as required. The test SNMP traps came through so everything seemed to be OK. 

However, the HP Storage P4000 Diagram View stays empty, no matter what I do or try. Also the advised trouble shooting steps (as stated on page 108 of the manual) don’t make any difference. Contacted a colleague of mine who noticed the same behavior in two other SCOM R2 MGs as well…
image

So time to use the other Bing, and soon I found this recent posting, stating:
image

Even though it’s an annoying bug, the relevant Alerts do come in. So hopefully HP will soon release a newer version of the HP Storage MP where this issue is fixed.

Oh, and while HP is fixing this issue, they also should take care of this (as stated on page 84 of the same manual):
image
This is REALLY stupid. Like buying a car but being told it can do anything but drive

8 comments:

steveburkett said...

Be careful of the discoveries on this one, they used to run every minute or so rather then every day, causing you some unnecessary pain.

Also I don't like how they lump all the HP storage products in to the same MP, we don't have EVA's, 3PAR, or X5000 systems, so don't particularly want them polluting our SCOM console. Would be nicer having a base MP and then you add in the remainder Storage products as you wish.

Marnix Wolf said...

Hi Steve.

I agree with you totally. As a matter of a fact I am going to adjust the discovery cycles since they wreck too much issues. Will post the outcome when ready.

Cheers,
Marnix

Stanislav Zhelyazkov said...
This comment has been removed by a blog administrator.
Stanislav Zhelyazkov said...

Hi Marnix,
I have this issue with HP Storage MP where the MP generates a lot of powershell.exe instances (around 20-30) and this is affecting RMS performance. I've disabled all discoveries for windows computers with the exception of SNMP which I am using for 3PAR storage but the issue remains. Have you stumbled on such issue? What overrides have to be made?

Marnix Wolf said...

Hi Stanislav Zhelyazkov.

The HP Storage MP isn't that good at all. As a matter of a fact, I am adjusting the MP for a customer of mine who runs a P4x00 SAN. I have exported the MP to xml format and started editing the MP in the MP Authoring Console. And boy, does this MP look bad.

In your case I would recommend the same approach and adjust the MP as required. Be careful though.

Soon I'll share my findings on my blog. However, I won't share the modified MP since I don't want to end up in a legal fight with HP about violating IP :(. I already know the outcome of such a feat...

Cheers,
Marnix

Stanislav Zhelyazkov said...

Hi Marnix,
I will try to log a case about the issue to the support team for the MP as I am HP employee. Will let you know with any findings.

Stanislav Zhelyazkov said...

Hi Marnix,
Here is the reason for my issue:
http://opsmgr.ru/Lists/Posts/Post.aspx?ID=295
Now I have to figure out what override to made to resolve it.

Vinod Bhat said...

Please try with HP Management Pack for SCOM 2.1.2. If you have any questions, please contact me -> vbhat at hp dot com.